Issues with dropping Diagnoses via IMO Search
Incident Report for Tangible Solutions
Resolved
Our partners at eMDs have confirmed the IMO Search issue has been resolved.

Please contact our Help Desk if you continue to have any issues.

Thank you!

Tangible Staff
Posted Dec 06, 2023 - 10:57 EST
Monitoring
We are receiving reports that the IMO Search function is returning and believe a fix has been implemented.
Please proceed with adding diagnoses as usual.

Thank you for your patience!

Tangible Staff
Posted Dec 06, 2023 - 10:35 EST
Investigating
We have received several reports regarding the IMO Search endlessly attempting to load or erroring out. Our partners over at eMDs are aware of the issue and are working towards a resolution.

We will provide an update once we have more information or when the issue is resolved.

Thank you for your cooperation and support!

Tangible Staff
Posted Dec 06, 2023 - 09:30 EST
This incident affected: eMDs Services.