Updox Latency Issues
Incident Report for Tangible Solutions
Resolved
Updox and eMDs have reported that the incident has been resolved. We will continue to monitor our environment to ensure all hosted clients are running optimally. If you are experiencing any system latency at this time, please contact our support desk at 800-393-9886 ext 8.

Thank you!
Tangible Staff
Posted Feb 12, 2024 - 08:15 EST
Investigating
Attention all clinics using Updox - The Updox and eMDs team are currently investigating reports of substantial slowness affecting eMDs across all modules. You may experience intermittent freezing at this time. We will post updates as new information comes to us.

We apologize for any inconvenience.

Thank you,
Tangible Staff
Posted Feb 09, 2024 - 17:26 EST
This incident affected: eMDs Services.