Issues with Prescriptions and Medications Module

Incident Report for Tangible Solutions

Resolved

System performance has remained stable, and this incident is now fully resolved.
Please reattempt any delayed prescriptions or medication orders.

Thank you
The Tangible Team
Posted Jun 11, 2026 - 10:14 EDT

Monitoring

CGM eMDs has confirmed that the vendor partner issue impacting prescription processing has been successfully resolved. All services are fully restored and operating normally.

Please go ahead and reattempt any delayed prescriptions or medication orders at this time.

Thank you for your patience,
The Tangible Team
Posted Jun 11, 2026 - 09:52 EDT

Update

CGM eMDs has confirmed that their engineers are actively investigating a vendor partner issue affecting prescription processing.

They are working to restore full service as quickly as possible, and we will provide another update as soon as we have more information.
Posted Jun 11, 2026 - 09:00 EDT

Identified

We are currently experiencing an issue where the prescription and medication module is inaccessible. This appears to be related to a service disruption with our partner, CGM eMDs.

The CGM eMDs team is actively investigating the issue. We do not have an ETA at the moment, but we will provide regular updates as we receive new information.

We apologize for any disruption this has cause.

The Tangible Team
Posted Jun 11, 2026 - 08:17 EDT
This incident affected: eMDs Surescripts.