System Wide Delays
Incident Report for Tangible Solutions
Resolved
Systems are operational now.
Posted Jun 07, 2022 - 17:28 EDT
Monitoring
The issue has been cleared and we are now monitoring.

Please contact the help desk line if you are still experiencing issues.

Thank you for your patience.

Tangible Staff
Posted Jun 07, 2022 - 14:11 EDT
Identified
The issue has been identified and we are working to bring our system back up to full capacity.

At this time, you may attempt to log back into the system, but please be aware that you may still experience some significant delays.

We thank you for your patience.

Tangible Staff
Posted Jun 07, 2022 - 10:29 EDT
Investigating
We are currently investigating the issue that is causing delays logging in. We advise the users that are currently logged in to not log off.

We are also aware of scanning or printing is causing significant delays.

Please bear with us while we continue to work towards a resolution.

Tangible Staff
Posted Jun 07, 2022 - 09:51 EDT
This incident affected: Happe-MDs Service and Happe-Desktop.