Updox Portal Down

Incident Report for Tangible Solutions

Resolved

This incident has been resolved.
Posted Feb 25, 2026 - 14:37 EST

Monitoring

Updox has reported that the issues connecting to the Updox Server have been resolved.

Please contact our support desk if you are still experiencing issues.

Thank you for your patience.

The Tangible Team
Posted Feb 25, 2026 - 11:04 EST

Investigating

Our partners at Updox are currently investigating an issue causing disruptions connecting to the Updox servers.

Direct updates from Updox can be found here: https://status.updox.com/

We apologize for the inconvenience.

The Tangible Team
Posted Feb 25, 2026 - 09:15 EST
This incident affected: eMDs Services.