Updox - Degraded System Performance
Incident Report for Tangible Solutions
Resolved
Updox has resolved the issue.

Thank you for your patience!

Tangible Solutions
Posted Jun 09, 2023 - 12:52 EDT
Monitoring
As of 10:11 AM, Updox has updated their status:

"A fix has been implemented and our technical operations team is continuing to monitor the results. We sincerely apologize for any impact this caused to you and your business."

Thank you,

Tangible Staff
Posted Jun 09, 2023 - 10:17 EDT
Identified
As of 8:26 AM, Updox has identified degraded system performance and is looking into a resolution. Their message is below:

"We are currently experiencing degraded system performance. Users are either unable to launch Updox or experiencing slowness. Our technical operations team is aware and currently investigating the issue. We sincerely apologize for any impact this causes to you and your business and will keep you updated on our progress."

You can also visit https://status.updox.com/ for their real time updates.

Thank you,

Tangible Staff
Posted Jun 09, 2023 - 09:50 EDT
This incident affected: eMDs Services.