Issues with Happe-MDs Website
Incident Report for Tangible Solutions
Resolved
This incident has be resolved and we thank you for your support.

Tangible Staff
Posted Jan 12, 2023 - 07:58 EST
Monitoring
Our Web Hosting partner has informed us that connectivity to our main site www.happe-mds.com as well as www.tangible.com/happe-mds-login has been restored. We are continuing to monitor the overall situation and will update this status as we receive more information.

Thank you again for your patience and support.

Tangible Staff
Posted Jan 10, 2023 - 13:23 EST
Identified
Our Web Hosting partner has alerted us that the problem has been identified in a Google Cloud datacenter causing the disruptions we have been facing this morning. They unfortunately have not provided us with an ETA on resolution.

In the meantime, please use the following alternative website to land on our website:
https://www1.happe-mds.com

Thank you for your patience and support.

Tangible Staff
Posted Jan 10, 2023 - 09:43 EST
Investigating
We are currently investigating an issue that is preventing a majority of devices from landing on our happe-mds.com and tangible.com/happe-mds-login websites.

Please attempt to land on the login box using this link:
https://system2.happe-mds.com/Citrix/XenApp/auth/login.aspx

If able, please continue to retry logging in as we continue to investigate.

We apologize for this inconvenience and thank you for your support.

Tangible Staff
Posted Jan 10, 2023 - 08:26 EST
This incident affected: Happe-MDs Website.