CGM eMDs has confirmed that the issue is now officially resolved and all services are fully operational.
If you or your clinic continue to experience any residual issues, please reach out to our support desk immediately so we can assist you.
Thank you again for your patience and understanding while we worked through this disruption.
— The Tangible Team
Posted May 14, 2026 - 15:40 EDT
Update
We are seeing services gradually return to normal. Please attempt to log in if you haven't already.
Note: While connectivity is returning, you may still encounter intermittent minor errors as the system stabilizes. We are continuing to monitor the situation closely until full stability is confirmed.
— The Tangible Team
Posted May 14, 2026 - 11:46 EDT
Identified
We are currently aware of a widespread issue affecting all CGM eMDs customers that prevents the application from opening.
CGM eMDs has confirmed they are actively working toward a resolution. While there is no estimated time for restoration at this moment, we are monitoring the situation closely and will provide updates as soon as more information becomes available.
We apologize for the disruption and appreciate your patience.