System Latency and Login Issues
Incident Report for Tangible Solutions
Resolved
This incident has been resolved.

Thank you for your understanding and support.

Tangible Staff
Posted Dec 06, 2022 - 08:04 EST
Monitoring
We have implemented a fix and are currently monitoring. Please contact the help desk line at 800-393-9886 Ext 8 if you have any other questions.

Thank you again for your cooperation and support.

Tangible Staff
Posted Dec 05, 2022 - 19:10 EST
Investigating
We are currently investigating an issue preventing users from logging into the system as well as overall system latency. If you are currently logged into the system, please do not log off at this time.

We will provide updates as soon as possible.

Thank you for your cooperation and support,

Tangible Staff
Posted Dec 05, 2022 - 18:24 EST
This incident affected: Happe-Desktop.