Unable to reach Happe-mds.com
Incident Report for Tangible Solutions
Resolved
This incident has been resolved.
Posted May 28, 2021 - 08:50 EDT
Update
As we continue to monitor the ongoing issue with our web hosting service, we have a workaround for any remaining users who cannot reach the Happe website.

If you are still receiving the error message "Page cannot be reached", please visit the following link:

https://www.tangible.com/happe-mds-login

Please be advised as this is a temporary solution to bypass our web hosting service. Once services for our main website are back up and operational, this website not be available.

We thank you for your time and understanding.

- Tangible Staff
Posted May 27, 2021 - 08:30 EDT
Update
We are receiving reports of users slowly getting access to the Happe website. Please continue to refresh your page if you have not done so already as the web hosting service is still experiencing issues.

- Tangible Staff
Posted May 26, 2021 - 12:19 EDT
Update
We are receiving reports of users being unable to reach the Happe website at this time.
Our website hosting service has issues that seem to be persisting throughout the nation, mainly affecting cities on the East Coast and the Mid West.
Please continue to periodically refresh your pages for our website and stay updated with these reports at: status.tangible.com

We thank you again for your continued patience and support.

- Tangible Staff
Posted May 26, 2021 - 11:12 EDT
Monitoring
Our web hosting service is back up and users should be able to reach www.happe-mds.com again.
We will continue to monitor this.
If you are still experiencing problems, please contact support at (800) 393 - 9886 Ext 8.

- Tangible Staff
Posted May 26, 2021 - 09:07 EDT
Identified
We are currently experiencing issues with our web hosting service that is affecting ability to reach www.happe-mds.com site to log in.
Please refer to status.tangible.com as we will be posting updates throughout this time.

We apologize for any inconveniences that this is causing you and we thank you for your patience.

- Tangible Staff
Posted May 26, 2021 - 08:51 EDT
This incident affected: Happe-MDs Website.