Issues with ePrescribing

Incident Report for Tangible Solutions

Resolved

This incident has been resolved.
Posted Nov 03, 2025 - 12:07 EST

Monitoring

We have been advised that the eMDs services have been restored and users should be able to prescribe medications again.
Please contact the support desk at 800-393-9886 ext 8 if this is not the case.

Thank you for your patience.
Posted Nov 03, 2025 - 10:47 EST

Investigating

We have been made aware of issues regarding prescribing medications.
Our partners at CGM eMDs are aware of the situation and are working towards a resolution.
There is currently no estimated resolution time, but we will update this status when we receive more information.

We apologize for the inconvenience.

Thank you,
Tangible Staff
Posted Nov 03, 2025 - 08:21 EST
This incident affected: eMDs Services.