Limited access to Updox Patient Portal, Clearinghouses and ICD-10 search
Incident Report for Tangible Solutions
Resolved
This incident has been resolved.
Posted Mar 22, 2022 - 08:29 EDT
Monitoring
The core issue affecting Updox Patient Portal, Clearing House Access, and ICD-10 Diagnosis Search has been identified. The issue has been resolved.

Please contact the support desk at 1-800-393-9886 opt. 8 if you are still experiencing these issues.

Thank you for your patience as we continue to monitor this situation.

-Tangible Staff
Posted Mar 21, 2022 - 13:34 EDT
Investigating
We are currently investigating the issue of users experiencing limited access to Updox Patient Portal, clearinghouses, and diagnosis search (ICD-10).

Workaround:

For Updox Patient Portal, please close taskman and try opening the patient portal again. You may have to click the red refresh arrow several times before it establishes.

When accessing clearinghouses if you are met with a 'site not secure' message please click 'advanced' and continue on to the website. You may have to click the refresh arrow several times before it establishes. For the ICD-10 box, please close the window with the small "x" on the window and retry.

We thank you for your patience and support in this matter as we work towards a resolution.

- Tangible Staff
Posted Mar 21, 2022 - 10:22 EDT
This incident affected: Happe-Desktop, eMDs Services, and Happe Internet Whitelist.