Unable to access Happe Login page
Incident Report for Tangible Solutions
Resolved
The issue preventing some clients from accessing the Happe-MDs website has been resolved. We apologize for any inconvenience caused by this issue and appreciate your patience.
Posted Jun 14, 2021 - 17:06 EDT
Update
Our web hosting service is back up and users should be able to reach www.happe-mds.com again.
We will continue to monitor this.
If you are still experiencing problems, please contact support at (800) 393-9886 opt. 8.
Posted Jun 14, 2021 - 15:13 EDT
Investigating
We are currently experiencing issues with our web hosting service that is affecting ability to reach www.happe-mds.com site to log in.
Please refer to status.tangible.com as we will be posting updates throughout this time.

The alternate login site is accessible at https://www.tangible.com/happe-mds-login/

We apologize for any inconveniences that this is causing you and we thank you for your patience.

- Tangible Staff
Posted Jun 14, 2021 - 14:58 EDT
This incident affected: Happe-MDs Website.