Difficulties Logging In/System Latency
Incident Report for Tangible Solutions
Resolved
This incident has be resolved. We thank you for your patience.

Tangible Staff
Posted Mar 02, 2022 - 08:08 EST
Monitoring
System latency and abnormal login times are seeing a steady improvement.

Thank you again for your patience while we work through this.

- Tangible Staff
Posted Mar 01, 2022 - 13:04 EST
Update
We are continuing to investigate system latency and abnormal login times.

We thank you again for your patience.

- Tangible Staff
Posted Mar 01, 2022 - 12:00 EST
Investigating
We are currently investigating longer than usual login times as well as overall system latency.

We thank you for your patience and support in this matter as we work towards a resolution.

- Tangible Staff
Posted Mar 01, 2022 - 11:02 EST
This incident affected: Happe-MDs Service.