Sudden Disconnections/Black Screen
Incident Report for Tangible Solutions
Resolved
We have determined the cause of the service disruption and we have resolved the issue.
We thank you for your patience and understanding.

Tangible Staff
Posted Jun 01, 2023 - 17:03 EDT
Investigating
We are currently investigating an issue where multiple users have been disconnected and are now having issues logging back in.
Please be advised - if you are currently at a black screen, please continue to wait as our system logs you back in.

We apologize for any inconveniences.

Tangible Staff
Posted Jun 01, 2023 - 16:23 EDT
This incident affected: Happe-Desktop.