EPrescribing Services are down
Incident Report for Tangible Solutions
Resolved
This incident has been resolved.
Posted Oct 21, 2023 - 10:46 EDT
Identified
ERX services are not functioning properly. Awaiting more information from CGM eMDs.
Posted Oct 21, 2023 - 09:00 EDT
This incident affected: eMDs Surescripts.