Happe-MDs Website Access Issue
Incident Report for Tangible Solutions
Resolved
This incident has been resolved.
Posted May 22, 2020 - 15:33 EDT
Monitoring
Happe-MDs website (www.happe-mds.com) is now reachable by those who could not reach it earlier. Issue appears to be resolved. If you are continuing to have problems, please call our Help Desk at 800-393-9886 option 8.

We will continue to monitor this issue to ensure resolution
Posted May 22, 2020 - 14:32 EDT
Update
As we continue to investigate the issue where some clients are not able to access our Happe-MDs website to login, for those affected, please use the following URL:

- https://www.tangible.com/testpage

The above temporary website access will provide those affected by this issue with the Happe-MDs Customer Login prompt. Please note, only those clients that are not able to access www.happe-mds.com need to use this alternate address.
Posted May 22, 2020 - 10:21 EDT
Update
We are continuing to investigate this issue.
Posted May 22, 2020 - 09:39 EDT
Investigating
We are investigating an issue where some clients are not able to access our Happe-MDs website. If you are experiencing this issue, we are working to identify the root cause at this time.
Posted May 22, 2020 - 09:04 EDT
This incident affected: Happe-MDs Website.